Get in touch
Back
Maintenance

Platform upgrade

Completed 2 Dec at 03:15pm UTC.

Console API
Completed

Posted 2 Dec at 03:15pm UTC.
Started

Platform dashboard and API may not be available due to the core system upgrades. All node API services are operating normally.

Posted 2 Dec at 12:45pm UTC.