Stuck Network - Polygon Mumbai

Resolved
Partial outage
Started 15 days ago Lasted 5 days

Affected

Updates
  • Resolved
    Resolved

    Polygon Foundation recommends transitioning to the Amoy testnet due to deprecation. Please proceed by setting up an Amoy testnet endpoint.

  • Investigating
    Investigating

    Polygon Matic Mumbai Testnet appears to have experienced a stall at block 48141035. Our team is currently investigating the issue and will promptly provide updates as they become available